Skip to content

What versions of iOS or Android phones are supported?

What versions of iOS or Android phones are supported?

Apple devices

Requires a minimum iOS version11.0 and above. Visit the iTunes store to update your software, or update from General Settings in your iPhone.

Android

Requires a minimum OS version 6.0 and above.


Not all mobile handsets are capable of accessing and using Mobile Banking App for Android. If you are unable to download the new app it may be due to your phone not supporting the correct operating system.

Download Mobile Banking App user guide

Mobile Banking App FAQs